<!doctype html>
<html lang="en-US">
<head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="profile" href="http://gmpg.org/xfn/11">

    <title>The All-new Razer Blade 15 – Built for Those Who Demand More | | Broadcast Newsroom</title>

<!-- All In One SEO Pack 3.4.2[203,297] -->

<meta name="keywords" content="news"/>

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://www.avid.broadcastnewsroom.com/#organization","url":"http://www.avid.broadcastnewsroom.com/","name":"Broadcast Newsroom","sameAs":[]},{"@type":"WebSite","@id":"http://www.avid.broadcastnewsroom.com/#website","url":"http://www.avid.broadcastnewsroom.com/","name":"Broadcast Newsroom","publisher":{"@id":"http://www.avid.broadcastnewsroom.com/#organization"}},{"@type":"WebPage","@id":"http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/#webpage","url":"http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/","inLanguage":"en-US","name":"The All-new Razer Blade 15 – Built for Those Who Demand More","isPartOf":{"@id":"http://www.avid.broadcastnewsroom.com/#website"},"breadcrumb":{"@id":"http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/#breadcrumblist"},"image":{"@type":"ImageObject","@id":"http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/#primaryimage","url":"http://www.avid.broadcastnewsroom.com/wp-content/uploads/2019/04/news5.jpg","width":417,"height":288},"primaryImageOfPage":{"@id":"http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/#primaryimage"},"datePublished":"2020-04-02T12:00:44+00:00","dateModified":"2020-04-02T12:00:44+00:00"},{"@type":"Article","@id":"http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/#article","isPartOf":{"@id":"http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/#webpage"},"author":{"@id":"http://www.avid.broadcastnewsroom.com/author/bn-staff/#author"},"headline":"The All-new Razer Blade 15 – Built for Those Who Demand More","datePublished":"2020-04-02T12:00:44+00:00","dateModified":"2020-04-02T12:00:44+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/#webpage"},"publisher":{"@id":"http://www.avid.broadcastnewsroom.com/#organization"},"articleSection":"News","image":{"@type":"ImageObject","@id":"http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/#primaryimage","url":"http://www.avid.broadcastnewsroom.com/wp-content/uploads/2019/04/news5.jpg","width":417,"height":288}},{"@type":"Person","@id":"http://www.avid.broadcastnewsroom.com/author/bn-staff/#author","name":"BN Staff","sameAs":[]},{"@type":"BreadcrumbList","@id":"http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"http://www.avid.broadcastnewsroom.com/","url":"http://www.avid.broadcastnewsroom.com/","name":"Broadcast newsroom"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/","url":"http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/","name":"The All-new Razer Blade 15 – Built for Those Who Demand More"}}]}]}</script>
<link rel="canonical" href="http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/"/>
<!-- All In One SEO Pack -->
<meta name="pwaforwp" content="wordpress-plugin"/>
                      <meta name="theme-color" content="#D5E0EB">
<link rel="manifest" href="/pwa-manifest.json">
<meta name="apple-mobile-web-app-title" content="BroadcastNewsroom">
            <meta name="application-name" content="BroadcastNewsroom">
            <meta name="apple-mobile-web-app-capable" content="yes">
            <meta name="mobile-web-app-capable" content="yes">
            <meta name="apple-touch-fullscreen" content="YES">
<link rel="apple-touch-startup-image" href="https://35.192.229.168/wp-content/uploads/2019/07/logo2.jpg">
<link rel="apple-touch-icon" sizes="192x192" href="https://35.192.229.168/wp-content/uploads/2019/07/logo2.jpg">
<link rel="apple-touch-icon-precomposed" sizes="192x192" href="https://35.192.229.168/wp-content/uploads/2019/07/logo2.jpg">
<link rel="apple-touch-icon" sizes="512x512" href="https://35.192.229.168/wp-content/uploads/2019/07/logo2.jpg">
<link rel="amphtml" href="http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/amp/?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=the-all-new-razer-blade-15-built-for-those-who-demand-more"/><meta name="generator" content="AMP for WP 1.0.38"/><link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="Broadcast Newsroom &raquo; Feed" href="http://www.avid.broadcastnewsroom.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Broadcast Newsroom &raquo; Comments Feed" href="http://www.avid.broadcastnewsroom.com/comments/feed/"/>
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.10.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">var mi_version='7.10.4';var mi_track_user=true;var mi_no_track_reason='';var disableStr='ga-disable-UA-79362-3';function __gaTrackerIsOptedOut(){return document.cookie.indexOf(disableStr+'=true')>-1;}if(__gaTrackerIsOptedOut()){window[disableStr]=true;}function __gaTrackerOptout(){document.cookie=disableStr+'=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';window[disableStr]=true;}if(mi_track_user){(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');__gaTracker('create','UA-79362-3','auto');__gaTracker('set','forceSSL',true);__gaTracker('require','displayfeatures');__gaTracker('send','pageview');}else{console.log("");(function(){var noopfn=function(){return null;};var noopnullfn=function(){return null;};var Tracker=function(){return null;};var p=Tracker.prototype;p.get=noopfn;p.set=noopfn;p.send=noopfn;var __gaTracker=function(){var len=arguments.length;if(len===0){return;}var f=arguments[len-1];if(typeof f!=='object'||f===null||typeof f.hitCallback!=='function'){console.log('Not running function __gaTracker('+arguments[0]+" ....) because you are not being tracked. "+mi_no_track_reason);return;}try{f.hitCallback();}catch(ex){}};__gaTracker.create=function(){return new Tracker();};__gaTracker.getByName=noopnullfn;__gaTracker.getAll=function(){return[];};__gaTracker.remove=noopfn;window['__gaTracker']=__gaTracker;})();}</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.avid.broadcastnewsroom.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4"}};!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script>
		<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-.1em!important;background:none!important;padding:0!important}</style>
	<link rel='stylesheet' id='wp-block-library-css' href='http://www.avid.broadcastnewsroom.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4' type='text/css' media='all'/>
<link rel='stylesheet' id='aioseop-toolbar-menu-css' href='http://www.avid.broadcastnewsroom.com/wp-content/plugins/all-in-one-seo-pack/css/admin-toolbar-menu.css?ver=3.4.2' type='text/css' media='all'/>
<link rel='stylesheet' id='featured-news-google-fonts-css' href='https://fonts.googleapis.com/css?family=Oswald:300,400,700' type='text/css' media='all'/>
<link rel='stylesheet' id='bootstrap-css' href='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/assets/bootstrap/css/bootstrap.min.css?ver=5.4' type='text/css' media='all'/>
<link rel='stylesheet' id='magazine-7-style-css' href='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/style.css?ver=5.4' type='text/css' media='all'/>
<link rel='stylesheet' id='featured-news-css' href='http://www.avid.broadcastnewsroom.com/wp-content/themes/featured-news/style.css?ver=1.0.3' type='text/css' media='all'/>
<link rel='stylesheet' id='font-awesome-v5-css' href='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/assets/font-awesome-v5/css/fontawesome-all.min.css?ver=5.4' type='text/css' media='all'/>
<link rel='stylesheet' id='slick-css' href='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/assets/slick/css/slick.min.css?ver=5.4' type='text/css' media='all'/>
<link rel='stylesheet' id='sidr-css' href='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/assets/sidr/css/jquery.sidr.dark.css?ver=5.4' type='text/css' media='all'/>
<link rel='stylesheet' id='magnific-popup-css' href='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/assets/magnific-popup/magnific-popup.css?ver=5.4' type='text/css' media='all'/>
<link rel='stylesheet' id='magazine-7-google-fonts-css' href='https://fonts.googleapis.com/css?family=Source%20Sans%20Pro:400,400i,700,700i|Montserrat:400,700&#038;subset=latin,latin-ext' type='text/css' media='all'/>
<link rel='stylesheet' id='addtoany-css' href='http://www.avid.broadcastnewsroom.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all'/>
<link rel='stylesheet' id='pwaforwp-style-css' href='http://www.avid.broadcastnewsroom.com/wp-content/plugins/pwa-for-wp/assets/css/pwaforwp-main.min.css?ver=1.7.9.3.1' type='text/css' media='all'/>
<script type='text/javascript'>//<![CDATA[
var monsterinsights_frontend={"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"http:\/\/www.avid.broadcastnewsroom.com","hash_tracking":"false"};
//]]></script>
<script type='text/javascript' src='http://www.avid.broadcastnewsroom.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js,qver=7.10.4.pagespeed.jm.vKagdo77HR.js'></script>
<script type='text/javascript' src='http://www.avid.broadcastnewsroom.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script src="http://www.avid.broadcastnewsroom.com/wp-includes,_js,_jquery,_jquery-migrate.min.js,qver==1.4.1+wp-content,_plugins,_add-to-any,_addtoany.min.js,qver==1.1.pagespeed.jc.eay7mLb9t2.js"></script><script>eval(mod_pagespeed_mUhmJEi5Tr);</script>
<script>eval(mod_pagespeed_2MlMjfgRko);</script>
<link rel='https://api.w.org/' href='http://www.avid.broadcastnewsroom.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.avid.broadcastnewsroom.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.avid.broadcastnewsroom.com/wp-includes/wlwmanifest.xml"/> 
<link rel='prev' title='Tofane Global Announces Its Next Acquisition: NOS International Carrier Services' href='http://www.avid.broadcastnewsroom.com/2020/04/02/tofane-global-announces-its-next-acquisition-nos-international-carrier-services/'/>
<meta name="generator" content="WordPress 5.4"/>
<link rel='shortlink' href='http://www.avid.broadcastnewsroom.com/?p=4539'/>
<link rel="alternate" type="application/json+oembed" href="http://www.avid.broadcastnewsroom.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.avid.broadcastnewsroom.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&#038;format=xml"/>

<script data-cfasync="false">window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");</script>
<script id="wpcp_disable_selection" type="text/javascript">//<![CDATA[
var image_save_msg='You Can Not Save images!';var no_menu_msg='Context Menu disabled!';var smessage="Content is protected !!";function disableEnterKey(e){if(e.ctrlKey){var key;if(window.event)key=window.event.keyCode;else
key=e.which;if(key==97||key==65||key==67||key==99||key==88||key==120||key==26||key==85||key==86||key==83||key==43){show_wpcp_message('You are not allowed to copy content or view source');return false;}else
return true;}}function disable_copy(e){var elemtype=e.target.nodeName;var isSafari=/Safari/.test(navigator.userAgent)&&/Apple Computer/.test(navigator.vendor);elemtype=elemtype.toUpperCase();var checker_IMG='';if(elemtype=="IMG"&&checker_IMG=='checked'&&e.detail>=2){show_wpcp_message(alertMsg_IMG);return false;}if(elemtype!="TEXT"&&elemtype!="TEXTAREA"&&elemtype!="INPUT"&&elemtype!="PASSWORD"&&elemtype!="SELECT"&&elemtype!="OPTION"&&elemtype!="EMBED"){if(smessage!==""&&e.detail==2)show_wpcp_message(smessage);if(isSafari)return true;else
return false;}}function disable_copy_ie(){var elemtype=window.event.srcElement.nodeName;elemtype=elemtype.toUpperCase();if(elemtype=="IMG"){show_wpcp_message(alertMsg_IMG);return false;}if(elemtype!="TEXT"&&elemtype!="TEXTAREA"&&elemtype!="INPUT"&&elemtype!="PASSWORD"&&elemtype!="SELECT"&&elemtype!="OPTION"&&elemtype!="EMBED"){return false;}}function reEnable(){return true;}document.onkeydown=disableEnterKey;document.onselectstart=disable_copy_ie;if(navigator.userAgent.indexOf('MSIE')==-1){document.onmousedown=disable_copy;document.onclick=reEnable;}function disableSelection(target){if(typeof target.onselectstart!="undefined")target.onselectstart=disable_copy_ie;else if(typeof target.style.MozUserSelect!="undefined"){target.style.MozUserSelect="none";}else
target.onmousedown=function(){return false}
target.style.cursor="default";}window.onload=function(){disableSelection(document.body);};
//]]></script>
	<script id="wpcp_disable_Right_Click" type="text/javascript">//<![CDATA[
document.ondragstart=function(){return false;}
function nocontext(e){return false;}document.oncontextmenu=nocontext;
//]]></script>
<style>.unselectable{-moz-user-select:none;-webkit-user-select:none;cursor:default}html{-webkit-touch-callout:none;-webkit-user-select:none;-khtml-user-select:none;-moz-user-select:none;-ms-user-select:none;user-select:none;-webkit-tap-highlight-color:rgba(0,0,0,0)}</style>
<script id="wpcp_css_disable_selection" type="text/javascript">var e=document.getElementsByTagName('body')[0];if(e){e.setAttribute('unselectable',on);}</script>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-8059070624613746",enable_page_level_ads:true});</script>        <style type="text/css">
                        .site-title a,
            .site-description {
                color: #f2ff05;
            }

            .site-branding .site-title {
                font-size: 100px;
            }

            @media only screen and (max-width: 640px) {
                .site-branding .site-title {
                    font-size: 60px;

                }

            @media only screen and (max-width: 640px) {
                .site-branding .site-title {
                    font-size: 50px;

                }

            

        </style>
        <link rel="icon" href="http://www.avid.broadcastnewsroom.com/wp-content/uploads/2019/04/cropped-logo1-32x32.jpg" sizes="32x32"/>
<link rel="icon" href="http://www.avid.broadcastnewsroom.com/wp-content/uploads/2019/04/cropped-logo1-192x192.jpg" sizes="192x192"/>
<link rel="apple-touch-icon" href="http://www.avid.broadcastnewsroom.com/wp-content/uploads/2019/04/cropped-logo1-180x180.jpg"/>
<meta name="msapplication-TileImage" content="http://www.avid.broadcastnewsroom.com/wp-content/uploads/2019/04/cropped-logo1-270x270.jpg"/>
</head>

<body class="post-template-default single single-post postid-4539 single-format-standard unselectable align-content-left">

    <div id="af-preloader">
        <div id="loader-wrapper">
            <div id="loader"></div>
        </div>
    </div>

<div id="page" class="site">
    <a class="skip-link screen-reader-text" href="#content">Skip to content</a>

<div class="magazine-7-woocommerce-store-notice">
    </div>
<header id="masthead" class="site-header">
        <div class="masthead-banner data-bg" data-background="http://www.broadcastnewsroom.com/wp-content/uploads/2019/12/cropped-header6.jpg">
        <div class="container">
            <div class="row">
                <div class="col-md-12">
                    <div class="site-branding">
                                                    <p class="site-title font-family-1">
                                <a href="http://www.avid.broadcastnewsroom.com/" rel="home">Broadcast Newsroom</a>
                            </p>
                        
                                                    <p class="site-description">News &amp; Information for Broadcast Professionals</p>
                                            </div>
                </div>
            </div>
        </div>
    </div>
    <nav id="site-navigation" class="main-navigation">
        <div class="container">
            <div class="row">
                <div class="col-md-12">
                    <div class="navigation-container">
                        
                        <div class="cart-search">
                            
                            <span class="af-search-click icon-search">
                                    <i class="fa fa-search"></i>
                            </span>

                        </div>
                        <span class="toggle-menu" aria-controls="primary-menu" aria-expanded="false">
                                <span class="screen-reader-text">Primary Menu</span>
                                 <i class="ham"></i>
                            </span>

                        <div id="primary-menu" class="menu"></div>




                    </div>
                </div>
            </div>
        </div>
    </nav>
</header>
<div id="af-search-wrap">
    <div class="af-search-box table-block">
        <div class="table-block-child v-center text-center">
            <form role="search" method="get" class="search-form" action="http://www.avid.broadcastnewsroom.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s"/>
				</label>
				<input type="submit" class="search-submit" value="Search"/>
			</form>        </div>
    </div>
    <div class="af-search-close af-search-click">
        <span></span>
        <span></span>
    </div>
</div>








    <div id="content" class="site-content">


        <div class="em-breadcrumbs font-family-1">
            <div class="container">
                <div class="row">
                    <div class="col-sm-12">
                        <div role="navigation" aria-label="Breadcrumbs" class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><ul class="trail-items" itemscope itemtype="http://schema.org/BreadcrumbList"><meta name="numberOfItems" content="5"/><meta name="itemListOrder" content="Ascending"/><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-begin"><a href="http://www.avid.broadcastnewsroom.com" rel="home" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1"/></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item"><a href="http://www.avid.broadcastnewsroom.com/2020/" itemprop="item"><span itemprop="name">2020</span></a><meta itemprop="position" content="2"/></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item"><a href="http://www.avid.broadcastnewsroom.com/2020/04/" itemprop="item"><span itemprop="name">April</span></a><meta itemprop="position" content="3"/></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item"><a href="http://www.avid.broadcastnewsroom.com/2020/04/02/" itemprop="item"><span itemprop="name">2</span></a><meta itemprop="position" content="4"/></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-end"><span itemprop="item"><span itemprop="name">The All-new Razer Blade 15 – Built for Those Who Demand More</span></span><meta itemprop="position" content="5"/></li></ul></div>                    </div>
                </div>
            </div>
        </div>


        <div class="container">
        <div class="row">
            <div class="col-sm-12">
                <div id="primary" class="content-area">
                    <main id="main" class="site-main">

                                                    <article id="post-4539" class="post-4539 post type-post status-publish format-standard has-post-thumbnail hentry category-news">
                                <div class="entry-content-wrap">
                                    <header class="entry-header">    
                    <div class="post-thumbnail full-width-image">
                    <img width="417" height="288" src="http://www.avid.broadcastnewsroom.com/wp-content/uploads/2019/04/news5.jpg" class="attachment-magazine-7-featured default-featured-img" alt="" srcset="http://www.avid.broadcastnewsroom.com/wp-content/uploads/2019/04/news5.jpg 417w, http://www.avid.broadcastnewsroom.com/wp-content/uploads/2019/04/news5-300x207.jpg 300w" sizes="(max-width: 417px) 100vw, 417px"/>                </div>
            
            <div class="header-details-wrapper">
        <div class="entry-header-details">
                            <div class="figure-categories figure-categories-bg">
                                        <ul class="cat-links"><li class="meta-category">
                             <a class="magazine-7-categories category-color-1" href="http://www.avid.broadcastnewsroom.com/category/news/" alt="View all posts in News"> 
                                 News
                             </a>
                        </li></ul>                </div>
                        <h1 class="entry-title">The All-new Razer Blade 15 – Built for Those Who Demand More</h1>            
        <span class="author-links">

        <span class="item-metadata posts-author">
            <span class="">By</span>
            <a href="http://www.avid.broadcastnewsroom.com/author/bn-staff/">
                BN Staff            </a>
        </span>


            <span class="item-metadata posts-date">
            60 mins ago        </span>
        </span>
                                
                    </div>
    </div>
</header><!-- .entry-header -->                                    

    <div class="entry-content">
        <div class="npqlp5e85e1f9120e5"><!-- BEGIN ADVERTSERVE CODE BLOCK -->
<script type="text/javascript">document.write('<scr'+'ipt src="http://ads.digitalmedianet.com/ads/servlet/view/banner/javascript/zone?zid=47&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');</script>
<!-- END ADVERTSERVE CODE BLOCK --></div><style type="text/css">@media screen and (min-width:1201px){.npqlp5e85e1f9120e5{display:block}}@media screen and (min-width:993px) and (max-width:1200px){.npqlp5e85e1f9120e5{display:block}}@media screen and (min-width:769px) and (max-width:992px){.npqlp5e85e1f9120e5{display:block}}@media screen and (min-width:768px) and (max-width:768px){.npqlp5e85e1f9120e5{display:block}}@media screen and (max-width:767px){.npqlp5e85e1f9120e5{display:block}}</style>
<div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/" data-a2a-title="The All-new Razer Blade 15 – Built for Those Who Demand More"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_google_gmail" href="https://www.addtoany.com/add_to/google_gmail?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Gmail" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_linkedin" href="https://www.addtoany.com/add_to/linkedin?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="LinkedIn" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_messenger" href="https://www.addtoany.com/add_to/facebook_messenger?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Facebook Messenger" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_outlook_com" href="https://www.addtoany.com/add_to/outlook_com?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Outlook.com" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_telegram" href="https://www.addtoany.com/add_to/telegram?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Telegram" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_sms" href="https://www.addtoany.com/add_to/sms?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="SMS" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_skype" href="https://www.addtoany.com/add_to/skype?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Skype" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><div>
<p class="bwalignc">
<i>More power. More cores. More frames. The new Razer Blade 15 is changing the game with 8-Core 10<sup>th</sup> Gen Intel&reg; Core&trade; i7 processors, state-of-the-art NVIDIA&reg; GeForce RTX SUPER&trade; GPUs, and ultra-fast 300Hz displays.</i>
</p>
<p>IRVINE, Calif.&#8211;(BUSINESS WIRE)&#8211;<a href="https://twitter.com/hashtag/300Hz?src=hash" target="_blank" rel="noopener noreferrer">#300Hz</a>&#8211;Razer&trade;, the leading global lifestyle brand for gamers, today revealed the next evolution of the Razer Blade 15 gaming laptop, featuring up to an 8-core 10<sup>th</sup> Gen Intel&reg; Core&trade; i7 processor, NVIDIA&reg; GeForce&reg; RTX SUPER&trade; GPUs, and a 300Hz display all packed into the signature black aluminum chassis. Complemented with a new keyboard layout, upgraded I/O, and abundant SSD storage, the Blade 15 gives users the power to play their best game, create their best work, and live their best life.
</p>
<p><a href="https://mms.businesswire.com/media/20200402005217/en/782844/5/Razer_Blade_15_E-2020_KV_-_Top_View.jpg"><img src="https://mms.businesswire.com/media/20200402005217/en/782844/21/Razer_Blade_15_E-2020_KV_-_Top_View.jpg"></a></p>
<p>
&ldquo;The new Razer Blade 15 is simply the best laptop we have ever created,&rdquo; said Brad Wildes, Senior Vice President of Razer&rsquo;s Systems Business Unit. &ldquo;We&rsquo;ve added numerous cutting-edge features and user improvements that were requested directly from the community to make the Blade 15 more than just a great laptop for gamers, but a great laptop for everyone.&rdquo;
</p>
<p>
<b>More Core Galore</b>
</p>
<p>
The Blade 15 is equipped with the latest 10<sup>th</sup> Gen Intel Core processors, including the 8-core i7-10875H &ndash; the first 8-core processor in any Razer Blade. The new 10<sup>th</sup> Gen Intel Core processors achieve even greater levels of performance over the last generation with up to 5.1Ghz clock speeds and up to 16MB of Intel Smart Cache. The increased core count paired with the incredibly fast Turbo Boost speed means faster compiling, lower render times, and overall higher framerates.
</p>
<p>
With the new 10<sup>th</sup> Gen Intel Core i7 processors come other welcomed upgrades including the new Intel Wi-Fi 6 AX201 (Gig+) wireless, capable of up to 2.4Gbps network speeds, and higher frequency 2933Mhz DDR4 memory.
</p>
<p>
<b>Feel the GeForce</b>
</p>
<p>
The Blade 15 is armed with the best of the best in graphics technology, with the all-new NVIDIA GeForce RTX 2080 SUPER GPU with Max-Q design. The new RTX SUPER GPU lineup features up to 25% increased performance over the original RTX GPUs, with up to 8GB of high-bandwidth GDDR6 memory and more ray tracing cores for advanced real-time ray tracing performance and faster framerates at higher settings in today&rsquo;s latest games. The RTX SUPER GPUs also provide additional benefits for virtual reality and content creation where the additional performance helps reduce render times and improve graphical fidelity.
</p>
<p>
<b>Hurtz So Good</b>
</p>
<p>
The Blade 15 features a 15.6&rdquo; Full-HD display with up to a 300Hz refresh rate for silky-smooth visuals and razor-sharp text. The display is flanked by ultra-thin bezels and topped-off with a matte finish for reduced glare.
</p>
<p>
For content creators and entertainment enthusiasts, the Blade 15 is also available with a 4K OLED display. The 4K OLED display covers 100% of the DCI-P3 color space and is available in both a touch and non-touch variant.
</p>
<p>
Each panel comes custom-calibrated for color accuracy, creating a rich and immersive experience, whether practicing on the road for the next big game or binging streams and chilling.
</p>
<p>
<b>A Cut Above the Rest</b>
</p>
<p>
The all-new<b> </b>Blade 15 with Windows 10 is the most powerful and feature-complete Razer Blade ever &ndash; combining the latest hardware with an ultra-compact design and refining it with meaningful upgrades including a refreshed keyboard, improved I/O, and increased storage options.
</p>
<p>
The refreshed keyboard features an extended right shift key and half-height directional keys paired with n-key rollover and anti-ghosting technology for more accurate typing. Powered by Razer Synapse 3, the keyboard is fully customizable with Razer Chroma RGB lighting covering a wide spectrum of 16.8 million colors and unique lighting effects.
</p>
<p>
Lining the sides is an abundance of connectivity options including USB 3.1 Gen 2 Type-A ports, an HDMI port, a USB Type-C port and a Thunderbolt&trade; 3 (USB-C) port. Select models of Blade 15 support charging via the USB Type-C ports with a 20V USB-C charger, for emergency situations, and a blazing-fast UHS-III SD card reader, for those needing to quickly move work from one device to another.
</p>
<p>
The all-new Blade 15 redefines the game by combining power, portability and functionality into a truly no-compromises solution.
</p>
<p>
<b>PRICE &amp; AVAILABILITY</b>
</p>
<p>
The all-new Razer Blade 15 will start at $1,599.99 USD / 1,799.99&euro; MSRP and will be available starting in May at Razer.com and through select retailers in the United States and Canada. The Razer Blade 15 will come soon to Razer.com and select retailers in Europe, China, Asia Pacific, and the Middle East.
</p><div class="ewjcl5e85e1f9121a6"><!-- BEGIN ADVERTSERVE CODE BLOCK -->
<script type="text/javascript">document.write('<scr'+'ipt src="http://ads.digitalmedianet.com/ads/servlet/view/banner/javascript/zone?zid=111&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');</script>
<!-- END ADVERTSERVE CODE BLOCK --></div><style type="text/css">@media screen and (min-width:1201px){.ewjcl5e85e1f9121a6{display:block}}@media screen and (min-width:993px) and (max-width:1200px){.ewjcl5e85e1f9121a6{display:block}}@media screen and (min-width:769px) and (max-width:992px){.ewjcl5e85e1f9121a6{display:block}}@media screen and (min-width:768px) and (max-width:768px){.ewjcl5e85e1f9121a6{display:block}}@media screen and (max-width:767px){.ewjcl5e85e1f9121a6{display:block}}</style>

<p>
For more information, please visit <a target="_blank" href="https://cts.businesswire.com/ct/CT?id=smartlink&amp;url=https%3A%2F%2Fwww.razer.com%2Fgaming-laptops%2Frazer-blade&amp;esheet=52197673&amp;newsitemid=20200402005217&amp;lan=en-US&amp;anchor=https%3A%2F%2Fwww.razer.com%2Fgaming-laptops%2Frazer-blade&amp;index=1&amp;md5=d9c87da50a44028f42dc40a0c19059b0" rel="nofollow noopener noreferrer" shape="rect">https://www.razer.com/gaming-laptops/razer-blade</a>.
</p>
<p>
<b>PRODUCT ASSETS</b>
</p>
<p>
Download product images <a target="_blank" href="https://cts.businesswire.com/ct/CT?id=smartlink&amp;url=http%3A%2F%2Frzr.to%2FRazer-Blade-15-2020-Assets-&amp;esheet=52197673&amp;newsitemid=20200402005217&amp;lan=en-US&amp;anchor=HERE&amp;index=2&amp;md5=cadafaf90df5f0ca8f3894ac530ca13b" rel="nofollow noopener noreferrer" shape="rect">HERE</a>
</p>
<p>
Download the product specification sheet <a target="_blank" href="https://cts.businesswire.com/ct/CT?id=smartlink&amp;url=http%3A%2F%2Frzr.to%2FBlade-15-2020-Tech-Specs&amp;esheet=52197673&amp;newsitemid=20200402005217&amp;lan=en-US&amp;anchor=HERE&amp;index=3&amp;md5=a994493a3829e8d357755ea1a9e38109" rel="nofollow noopener noreferrer" shape="rect">HERE</a>
</p>
<p>
<b>ABOUT RAZER</b>
</p>
<p>
Razer&trade; is the world&rsquo;s leading lifestyle brand for gamers.
</p>
<p>
The triple-headed snake trademark of Razer is one of the most recognized logos in the global gaming and esports communities. With a fan base that spans every continent, the company has designed and built the world&rsquo;s largest gamer-focused ecosystem of hardware, software and services.
</p>
<p>
Razer&rsquo;s award-winning hardware includes high-performance gaming peripherals and Blade gaming laptops.
</p>
<p>
Razer&rsquo;s software platform, with over 80 million users, includes Razer Synapse (an Internet of Things platform), Razer Chroma (a proprietary RGB lighting technology system), and Razer Cortex (a game optimizer and launcher).
</p>
<p>
In services, Razer Gold is one of the world&rsquo;s largest virtual credit services for gamers, and Razer Fintech is one of the largest offline-to-online digital payment networks in SE Asia.
</p>
<p>
Founded in 2005 and dual-headquartered in Irvine and Singapore, Razer has 16 offices worldwide and is recognized as the leading brand for gamers in the USA, Europe and China. Razer is listed on the Hong Kong Stock Exchange (Stock Code: 1337).
</p>
<p class="bwalignc">
<b>Razer &#8211; For Gamers. By Gamers.<sup>&trade;</sup></b>
</p>
<p><img alt="" src="https://cts.businesswire.com/ct/CT?id=bwnews&amp;sty=20200402005217r1&amp;sid=web01&amp;distro=nx&amp;lang=en" style="width:0;height:0"><span class="bwct31415"></span></p>
<p><b>Contacts</b> </p>
<p>
<b>Americas<span class="bwuline"><br/></span></b>Kham Lam<br/>
<br/><a target="_blank" href="mailto:Kham.Lam@razer.com" rel="nofollow noopener noreferrer" shape="rect">Kham.Lam@razer.com </a>
</p>
<p>
<b>EMEA<br/>
<br/></b>Maren Epping<br/>
<br/><a target="_blank" href="mailto:Maren.Epping@razer.com" rel="nofollow noopener noreferrer" shape="rect">Maren.Epping@razer.com </a>
</p>
<p>
<b>China<br/>
<br/></b>Evita Zhang<br/>
<br/><a target="_blank" href="mailto:Evita.Zhang@razer.com" rel="nofollow noopener noreferrer" shape="rect">Evita.Zhang@razer.com </a>
</p>
<p>
<b>Asia Pacific</b><br/>Vanessa Li<br/>
<br/><a target="_blank" href="mailto:Vanessa.Li@razer.com" rel="nofollow noopener noreferrer" shape="rect">Vanessa.Li@razer.com </a>
</p>
<p>
<b>Global<br/>
<br/></b>Jan Horak<br/>
<br/><a target="_blank" href="mailto:Jan.Horak@razer.com" rel="nofollow noopener noreferrer" shape="rect">Jan.Horak@razer.com</a>
</p>
</div>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/" data-a2a-title="The All-new Razer Blade 15 – Built for Those Who Demand More"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_google_gmail" href="https://www.addtoany.com/add_to/google_gmail?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Gmail" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_linkedin" href="https://www.addtoany.com/add_to/linkedin?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="LinkedIn" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_messenger" href="https://www.addtoany.com/add_to/facebook_messenger?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Facebook Messenger" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_flipboard" href="https://www.addtoany.com/add_to/flipboard?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Flipboard" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_outlook_com" href="https://www.addtoany.com/add_to/outlook_com?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Outlook.com" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_telegram" href="https://www.addtoany.com/add_to/telegram?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Telegram" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_sms" href="https://www.addtoany.com/add_to/sms?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="SMS" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_skype" href="https://www.addtoany.com/add_to/skype?linkurl=http%3A%2F%2Fwww.avid.broadcastnewsroom.com%2F2020%2F04%2F02%2Fthe-all-new-razer-blade-15-built-for-those-who-demand-more%2F&amp;linkname=The%20All-new%20Razer%20Blade%2015%20%E2%80%93%20Built%20for%20Those%20Who%20Demand%20More" title="Skype" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><div class="ynyuh5e85e1f912144"><!-- BEGIN ADVERTSERVE CODE BLOCK -->
<script type="text/javascript">document.write('<scr'+'ipt src="http://ads.digitalmedianet.com/ads/servlet/view/banner/javascript/zone?zid=47&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');</script>
<!-- END ADVERTSERVE CODE BLOCK --></div><style type="text/css">@media screen and (min-width:1201px){.ynyuh5e85e1f912144{display:block}}@media screen and (min-width:993px) and (max-width:1200px){.ynyuh5e85e1f912144{display:block}}@media screen and (min-width:769px) and (max-width:992px){.ynyuh5e85e1f912144{display:block}}@media screen and (min-width:768px) and (max-width:768px){.ynyuh5e85e1f912144{display:block}}@media screen and (max-width:767px){.ynyuh5e85e1f912144{display:block}}</style>
<div class="nnojk5e85e1f91222e"><script type="text/javascript">atOptions={'key':'fc4b92dfeaffbee4acea257f5634a2db','format':'iframe','height':90,'width':728,'params':{}};document.write('<scr'+'ipt type="text/javascript" src="http'+(location.protocol==='https:'?'s':'')+'://www.bcloudhost.com/fc4b92dfeaffbee4acea257f5634a2db/invoke.js"></scr'+'ipt>');</script></div><style type="text/css">@media screen and (min-width:1201px){.nnojk5e85e1f91222e{display:block}}@media screen and (min-width:993px) and (max-width:1200px){.nnojk5e85e1f91222e{display:block}}@media screen and (min-width:769px) and (max-width:992px){.nnojk5e85e1f91222e{display:block}}@media screen and (min-width:768px) and (max-width:768px){.nnojk5e85e1f91222e{display:block}}@media screen and (max-width:767px){.nnojk5e85e1f91222e{display:block}}</style>
                    <div class="post-item-metadata entry-meta">
                            </div>
                
	<nav class="navigation post-navigation" role="navigation" aria-label="Continue Reading">
		<h2 class="screen-reader-text">Continue Reading</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://www.avid.broadcastnewsroom.com/2020/04/02/tofane-global-announces-its-next-acquisition-nos-international-carrier-services/" rel="prev"><span class="em-post-navigation">Previous</span> Tofane Global Announces Its Next Acquisition: NOS International Carrier Services</a></div></div>
	</nav>            </div><!-- .entry-content -->


                                </div>
                                                            </article>
                        
                    </main><!-- #main -->
                </div><!-- #primary -->
                                
<aside id="secondary" class="widget-area">
	<div id="search-2" class="widget magazine-7-widget widget_search"><form role="search" method="get" class="search-form" action="http://www.avid.broadcastnewsroom.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s"/>
				</label>
				<input type="submit" class="search-submit" value="Search"/>
			</form></div><div id="custom_html-4" class="widget_text widget magazine-7-widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- IBN Sidebar 1 -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-8059070624613746" data-ad-slot="5388103686" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div><div id="custom_html-2" class="widget_text widget magazine-7-widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- BEGIN ADVERTSERVE CODE BLOCK -->
<script type="text/javascript">document.write('<scr'+'ipt src="http://ads.digitalmedianet.com/ads/servlet/view/banner/javascript/zone?zid=223&pid=0&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');</script>
<!-- END ADVERTSERVE CODE BLOCK --></div></div><div id="custom_html-7" class="widget_text widget magazine-7-widget widget_custom_html"><h2 class="widget-title widget-title-1"><span>Video News</span></h2><div class="textwidget custom-html-widget"><script type="text/javascript">(function(v,i){var scp=v.createElement("script"),config={ChannelID:'59c4d02d28a06117d405b228',AdUnitType:'2',PublisherID:'221762775612026',PlacementID:'pltuTGePbmjAvAtXjtg',DivID:'',IAB_Category:'IAB3-4',Keywords:'Software',Language:'en-us',BG_Color:'',Text_Color:'',Font:'',FontSize:'',};scp.src='https://s.vi-serve.com/tagLoader.js';scp.type="text/javascript";scp.onload=function(){i[btoa('video intelligence start')].init(config);};(v.getElementsByTagName('head')[0]||v.documentElement.appendChild(v.createElement('head'))).appendChild(scp);})(document,window);</script></div></div><div id="categories-2" class="widget magazine-7-widget widget_categories"><h2 class="widget-title widget-title-1"><span>Categories</span></h2><form action="http://www.avid.broadcastnewsroom.com" method="get"><label class="screen-reader-text" for="cat">Categories</label><select name='cat' id='cat' class='postform'>
	<option value='-1'>Select Category</option>
	<option class="level-0" value="56">3D Printing</option>
	<option class="level-0" value="26">4K</option>
	<option class="level-0" value="42">60fps</option>
	<option class="level-0" value="51">8K</option>
	<option class="level-0" value="82">Automation</option>
	<option class="level-0" value="28">Avid</option>
	<option class="level-0" value="22">Broadcast</option>
	<option class="level-0" value="120">Camera</option>
	<option class="level-0" value="29">CES Asia</option>
	<option class="level-0" value="65">Community</option>
	<option class="level-0" value="14">Compositing</option>
	<option class="level-0" value="21">Content</option>
	<option class="level-0" value="18">Content Creation</option>
	<option class="level-0" value="27">Dailies</option>
	<option class="level-0" value="12">DIT</option>
	<option class="level-0" value="103">Education</option>
	<option class="level-0" value="61">Electronics</option>
	<option class="level-0" value="115">Encoder</option>
	<option class="level-0" value="3">Feature</option>
	<option class="level-0" value="31">Finishing</option>
	<option class="level-0" value="13">Grading</option>
	<option class="level-0" value="50">IBC</option>
	<option class="level-0" value="25">Image Processing</option>
	<option class="level-0" value="41">IP Video</option>
	<option class="level-0" value="46">IQS</option>
	<option class="level-0" value="43">Lighting</option>
	<option class="level-0" value="47">Manufacturing</option>
	<option class="level-0" value="87">Metadata</option>
	<option class="level-0" value="108">Monitor</option>
	<option class="level-0" value="15">Music</option>
	<option class="level-0" value="11">Music Video</option>
	<option class="level-0" value="66">NAB</option>
	<option class="level-0" value="2">News</option>
	<option class="level-0" value="113">People</option>
	<option class="level-0" value="10">Post</option>
	<option class="level-0" value="77">Production</option>
	<option class="level-0" value="9">ProRes</option>
	<option class="level-0" value="5">Review</option>
	<option class="level-0" value="48">Robotics</option>
	<option class="level-0" value="19">Storage</option>
	<option class="level-0" value="16">Streaming</option>
	<option class="level-0" value="30">Technology</option>
	<option class="level-0" value="4">Top Story</option>
	<option class="level-0" value="93">Transcription</option>
	<option class="level-0" value="114">Translation</option>
	<option class="level-0" value="109">Tutorial</option>
	<option class="level-0" value="76">UHD</option>
	<option class="level-0" value="20">Video</option>
	<option class="level-0" value="52">Video Editing</option>
	<option class="level-0" value="24">Video processor</option>
	<option class="level-0" value="23">Videowall</option>
	<option class="level-0" value="17">VR</option>
	<option class="level-0" value="8">Workflow</option>
</select>
</form>
<script type="text/javascript">//<![CDATA[
(function(){var dropdown=document.getElementById("cat");function onCatChange(){if(dropdown.options[dropdown.selectedIndex].value>0){dropdown.parentNode.submit();}}dropdown.onchange=onCatChange;})();
//]]></script>

			</div><div id="custom_html-8" class="widget_text widget magazine-7-widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- IBN Sidebar 2 -->
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-8059070624613746" data-ad-slot="8472845291"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div></div>		<div id="recent-posts-2" class="widget magazine-7-widget widget_recent_entries">		<h2 class="widget-title widget-title-1"><span>Recent Posts</span></h2>		<ul>
											<li>
					<a href="http://www.avid.broadcastnewsroom.com/2020/04/02/the-all-new-razer-blade-15-built-for-those-who-demand-more/" aria-current="page">The All-new Razer Blade 15 – Built for Those Who Demand More</a>
									</li>
											<li>
					<a href="http://www.avid.broadcastnewsroom.com/2020/04/02/tofane-global-announces-its-next-acquisition-nos-international-carrier-services/">Tofane Global Announces Its Next Acquisition: NOS International Carrier Services</a>
									</li>
											<li>
					<a href="http://www.avid.broadcastnewsroom.com/2020/04/02/triton-digital-releases-australian-podcast-ranker-for-17-february-through-15-march-reporting-period-expands-to-include-all-australian-top-100-category/">Triton Digital Releases Australian Podcast Ranker for 17 February through 15 March Reporting Period; Expands to Include All-Australian Top 100 Category</a>
									</li>
											<li>
					<a href="http://www.avid.broadcastnewsroom.com/2020/04/02/fox-news-channel-and-facebook-to-present-a-virtual-town-hall-on-the-global-coronavirus-pandemic-on-thursday-april-2/">Fox News Channel and Facebook to Present a Virtual Town Hall on the Global Coronavirus Pandemic on Thursday, April 2</a>
									</li>
											<li>
					<a href="http://www.avid.broadcastnewsroom.com/2020/04/02/tegna-comments-on-standard-general-filing/">TEGNA Comments on Standard General Filing</a>
									</li>
					</ul>
		</div><div id="archives-2" class="widget magazine-7-widget widget_archive"><h2 class="widget-title widget-title-1"><span>Archives</span></h2>		<ul>
				<li><a href='http://www.avid.broadcastnewsroom.com/2020/04/'>April 2020</a></li>
	<li><a href='http://www.avid.broadcastnewsroom.com/2020/03/'>March 2020</a></li>
	<li><a href='http://www.avid.broadcastnewsroom.com/2020/02/'>February 2020</a></li>
	<li><a href='http://www.avid.broadcastnewsroom.com/2020/01/'>January 2020</a></li>
	<li><a href='http://www.avid.broadcastnewsroom.com/2019/12/'>December 2019</a></li>
	<li><a href='http://www.avid.broadcastnewsroom.com/2019/11/'>November 2019</a></li>
	<li><a href='http://www.avid.broadcastnewsroom.com/2019/10/'>October 2019</a></li>
	<li><a href='http://www.avid.broadcastnewsroom.com/2019/09/'>September 2019</a></li>
	<li><a href='http://www.avid.broadcastnewsroom.com/2019/08/'>August 2019</a></li>
	<li><a href='http://www.avid.broadcastnewsroom.com/2019/07/'>July 2019</a></li>
	<li><a href='http://www.avid.broadcastnewsroom.com/2019/06/'>June 2019</a></li>
	<li><a href='http://www.avid.broadcastnewsroom.com/2019/05/'>May 2019</a></li>
	<li><a href='http://www.avid.broadcastnewsroom.com/2019/04/'>April 2019</a></li>
		</ul>
			</div><div id="custom_html-9" class="widget_text widget magazine-7-widget widget_custom_html"><h2 class="widget-title widget-title-1"><span>Partner Sites</span></h2><div class="textwidget custom-html-widget"><p><strong>IT Business Net<br/></strong><a href="http://www.ITBusinessNet.com">http://www.ITBusinessNet.com</a></p>
<p><strong>Digital Producer Magazine</strong><br/><a href="http://www.DigitalProducer.com">http://www.DigitalProducer.com</a></p>
<p><strong>Digital Media Net Media Hub</strong><br/><a href="http://www.DigitalMediaNet.com">http://www.DigitalMediaNet.com</a></p>
<p><strong>Consumer Electronics Net</strong><br/><a href="http://www.ConsumerElectronicsNet.com">http://www.ConsumerElectronicsNet.com</a></p>
<p><strong>Broadcast Newsroom</strong><br/><a href="http://www.BroadcastNewsroom.com">http://www.BroadcastNewsroom.com</a></p>
<p><strong>Health Technology Net</strong><br/><a href="http://www.HealthTechnologyNet.com">http://www.HealthTechnologyNet.com</a></p>
<p><strong>ByteSteam - Crypto &amp; Blockchain</strong><br/><a href="http://www.ByteSteam.com">http://www.ByteSteam.com</a></p>
<p><strong>Free Digital Stock Photos</strong><br/><a href="http://www.DigitalStockResources.com">http://www.DigitalStockResources.com</a></p></div></div></aside><!-- #secondary -->
            </div>
        </div>
    </div>


</div>


<footer class="site-footer">
            <div class="primary-footer">
        <div class="container">
            <div class="row">
                <div class="col-sm-12">
                    <div class="row">
                                                            <div class="primary-footer-area footer-first-widgets-section col-md-4 col-sm-12">
                                    <section class="widget-area">
                                            <div id="custom_html-6" class="widget_text widget magazine-7-widget widget_custom_html"><div class="textwidget custom-html-widget"><amp-auto-ads type="adsense" data-ad-client="ca-pub-8059070624613746">
</amp-auto-ads></div></div>                                    </section>
                                </div>
                            
                        
                                                    <div class="primary-footer-area footer-third-widgets-section col-md-4  col-sm-12">
                                <section class="widget-area">
                                    <div id="custom_html-3" class="widget_text widget magazine-7-widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-8059070624613746",enable_page_level_ads:true});</script></div></div>                                </section>
                            </div>
                                                                    </div>
                </div>
            </div>
        </div>
    </div>
    
                <div class="site-info">
        <div class="container">
            <div class="row">
                <div class="col-sm-12">
                                                                Copyright &copy; All rights reserved.                                                                                    <span class="sep"> | </span>
                        <a href=https://afthemes.com/products/magazine-7 target='_blank'>Magazine 7</a> by AF themes.                                    </div>
            </div>
        </div>
    </div>
</footer>
</div>
<a id="scroll-up" class="secondary-color">
    <i class="fa fa-angle-up"></i>
</a>
	<div id="wpcp-error-message" class="msgmsg-box-wpcp warning-wpcp hideme"><span>error: </span>Content is protected !!</div>
	<script>var timeout_result;function show_wpcp_message(smessage){if(smessage!==""){var smessage_text='<span>Alert: </span>'+smessage;document.getElementById("wpcp-error-message").innerHTML=smessage_text;document.getElementById("wpcp-error-message").className="msgmsg-box-wpcp warning-wpcp showme";clearTimeout(timeout_result);timeout_result=setTimeout(hide_message,3000);}}function hide_message(){document.getElementById("wpcp-error-message").className="msgmsg-box-wpcp warning-wpcp hideme";}</script>
		<style>@media print{body *{display:none!important}body:after{content:"You are not allowed to print preview this page, Thank you"}}</style>
		<style type="text/css">
	#wpcp-error-message {
	    direction: ltr;
	    text-align: center;
	    transition: opacity 900ms ease 0s;
	    z-index: 99999999;
	}
	.hideme {
    	opacity:0;
    	visibility: hidden;
	}
	.showme {
    	opacity:1;
    	visibility: visible;
	}
	.msgmsg-box-wpcp {
		border-radius: 10px;
		color: #555;
		font-family: Tahoma;
		font-size: 11px;
		margin: 10px;
		padding: 10px 36px;
		position: fixed;
		width: 255px;
		top: 50%;
  		left: 50%;
  		margin-top: -10px;
  		margin-left: -130px;
  		-webkit-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		-moz-box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
		box-shadow: 0px 0px 34px 2px rgba(242,191,191,1);
	}
	.msgmsg-box-wpcp span {
		font-weight:bold;
		text-transform:uppercase;
	}
	.error-wpcp {		background:#ffecec url('http://www.avid.broadcastnewsroom.com/wp-content/plugins/wp-content-copy-protector/images/error.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.success {
		background:#e9ffd9 url('http://www.avid.broadcastnewsroom.com/wp-content/plugins/wp-content-copy-protector/images/success.png') no-repeat 10px 50%;
		border:1px solid #a6ca8a;
	}
	.warning-wpcp {
		background:#ffecec url('http://www.avid.broadcastnewsroom.com/wp-content/plugins/wp-content-copy-protector/images/warning.png') no-repeat 10px 50%;
		border:1px solid #f5aca6;
	}
	.notice {
		background:#e3f7fc url('http://www.avid.broadcastnewsroom.com/wp-content/plugins/wp-content-copy-protector/images/notice.png') no-repeat 10px 50%;
		border:1px solid #8ed9f6;
	}
    </style>
<script type='text/javascript' src='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/assets/slick/js/slick.min.js?ver=5.4'></script>
<script type='text/javascript' src='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/assets/bootstrap/js/bootstrap.min.js?ver=5.4'></script>
<script type='text/javascript' src='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/assets/sidr/js/jquery.sidr.min.js?ver=5.4'></script>
<script type='text/javascript' src='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/assets/magnific-popup/jquery.magnific-popup.min.js?ver=5.4'></script>
<script type='text/javascript' src='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/assets/jquery-match-height/jquery.matchHeight.min.js?ver=5.4'></script>
<script type='text/javascript' src='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/assets/theiaStickySidebar/theia-sticky-sidebar.min.js?ver=5.4'></script>
<script type='text/javascript' src='http://www.avid.broadcastnewsroom.com/wp-content/themes/magazine-7/assets/script.js?ver=5.4'></script>
<script type='text/javascript' src='https://www.avid.broadcastnewsroom.com/pwa-register-sw.js?ver=1.7.9.3.1'></script>
<script type='text/javascript' src='http://www.avid.broadcastnewsroom.com/wp-includes/js/wp-embed.min.js?ver=5.4'></script>

</body>
</html>
